Installation

The Waylay Python SDK is available as waylay-beta on PyPi, so installing it only requires:

pip install waylay-beta

or

pip install --upgrade waylay-beta

when you want to upgrade to the latest version.

Prerequisites

waylay-beta requires python 3.6 or above. It is tested on 3.6, 3.7 and 3.8.

Dependencies are automatically installed or reused when present. Noteable ones are:

  • pandas (tested version 1.1.1)
  • numpy (tested version 1.19.1)

Older versions (present before installation) should work but were not explicitely tested by us.

Usage in jupyter notebooks

See also python-sdk examples on the public demo repository for a full installation procedure when using Anaconda or Miniconda and python notebooks as primary environment.